INTRODUCTION

Généralités

La thématique principale de Proteus V.8 est l'intégration. Le développement de la version V8 a été conduit en tenant compte des différents aspects qui concourent au développement d'un projet électronique afin d'en améliorer la productivité. Pour atteindre ce résultat, nous avons reconsidéré globalement l'architecture du produit pour aboutir à une interface unifiée, une base de données commune et une netlist temps réel à tous les modules.

Interface unifiée

Proteus V8 contient une seule application (PDS.EXE). Cette application est l'ossature qui regroupe toutes les fonctionnalités de Proteus. Les modules ISIS, ARES ou la visualisation 3D sont tous présents dans des onglets de l'application et accèdent ainsi à une seule base de données commune.

Voir également

Interface

Base de données commune

La base de données commune regroupe les informations sur tous les éléments utilisés dans le projet. Un élément contient à la fois le composant du schéma et son empreinte physique ainsi que les propriétés "système". L'accès partagé de toutes les applications à la base de données rend possible de nombreuses fonctionnalités nouvelles, qui apparaîtront tout au long du cycle de vie de Proteus V.8.

Netlist temps réel

La mise à jour en temps réel de la base de données commune, couplée à celle de la netlist, permet à tous les modules d'actualiser automatiquement toutes les modifications faites à un instant T. L'exemple le plus évident est celui de l'ajout d'une connexion dans ISIS qui génère automatiquement un lien de chevelu dans ARES. Mais nous allons plus loin car la nouvelle liste du matériel (nomenclature) contient également un visionneur temps réel, de même que la visualisation 3D ou l'explorateur de projet qui sont reliés à la netlist.

Voir également

Netlists

Saisie de schéma & Circuit imprimé

Les opérations de base dans les modules ISIS et ARES sont pour la plupart identiques à celles des versions précédentes de Proteus. Les principales différences sont liées aux évolutions de l'ossature globale (Interface) qui induit un nouveau cycle de développement du logiciel. Un résumé des modifications pour chaque module est indiqué dans les liens ci-dessous:

Voir également:

Saisie de schéma

Circuit imprimé

Netlists

Liste du matériel/Nomenclature

La liste du matériel ou nomenclature de Proteus V8 a été totalement revisitée pour devenir un module à part entière. Les nouvelles fonctionnalités incluent:

  • Vision temps réel du rapport de nomenclature.

  • Présentation WISIWYG du rapport.

  • Nouvel éditeur de propriétés pour ajouter et formatter des données dans la nomenclature et les composants du schéma.

  • Nouveaux formats de sortie pour exporter en PDF ou MS Excel.

  • Contrôle utilisateur complet sur les catégories et les champs du rapport.

Voir également

Nomenclature

Visualisation 3D

Le visionneur 3D a également évolué (support de DirectX) avec une nette amélioration de la vitesse du rendu (gestion multi-coeurs). La visualisation est mise à jour automatiquement en relation avec les modifications apportées au circuit.

Voir également

Visionneur 3D

EDI VSM Studio

L'environnement de développement intégré VSM Studio est à présent totalement intégré à l'interface de Proteus V8, ce qui facilite la communication entre le schéma (hardware) et les éléments (firmware) du projet enfoui.

Les nouvelle fonctionnalités incluent:

  • Auto-création du squelette du firmware grâce à un assistant de projet (relié à la l'environnement de compilation choisi et au microcontrôleur).
  • Auto-placement et alimentation du processeur grâce à un assistant de projet.
  • Transmission automatique du firmware depuis VSM studio vers le schéma lorsque la compilation est réussie.
  • Débogage complet dans VSM Studio.
  • Technologie de fenêtre popup qui permet d'ancrer dans VSM Studio des éléments du schéma lors du débogage.

Voir également

VSM Studio


Installation

INSTALLATION DU LOGICIEL

L'installation de Proteus V8 diffère des versions précédentes. La structure des dossiers et les entrées d'enregistrement ont changé, comme détaillé ci-dessous :

Installer Proteus

Fichiers d'installation

Comme dans les versions précédentes de Proteus, plusieurs groupes de fichiers sont installés avec le logiciel :

  • Dossier BIN (Lecture seule)
  • Dossier Models (Lecture seule)
  • Dossier Library (Lecture/Ecriture)
  • Dossier Templates (Lecture/Ecriture)
  • Dossier Updates (Lecture/Ecriture)
  • Dossier Help (Lecture seule)
  • Dossier Samples Lecture/Ecriture)
  • Dossier VSM Studio (Lecture seule)
  • Dossier Datasheets (Lecture/Ecriture)

Le dossiers pour lesquels l'utilisateur pour souhaiter un accès en lecture/écriture ne sont pas installés dans le dossier Program Data (Application Data pour Windows XP), alors que ceux qui nécessitent un accès en lecture seule sont installés dans le dossier Program Files.

Migration des bibliothèques et autres fichiers de Proteus V.7xx à V.8

Proteus V8 installe les dossiers qui nécessitent un accès en écriture dans une arborescence différente de celle utilisée dans l’installation de Proteus 7.xx. La migration se fait normalement de manière automatique mais peut dépendre de la configuration de votre Proteus V7.

Installation V7.xx par défaut

C’est la situation normale d’installation de Proteus V7, qui ne contient qu’un seul dossier bibliothèque (LIBRARY), que vous n’avez pas déplacé, modifié et où vous n'avez pas ajouté d’autres chemins d’accès à des bibliothèques.

Après l’installation de Proteus V.8, l’utilitaire d’import de projet Proteus vous proposera de copier vos bibliothèques utilisateurs, les styles et les gabarits dans les nouveaux emplacements de Proteus V8.

Aucune intervention de l’utilisateur n’est requise dans ce cas.

Si vous n’utilisez pas l’utilitaire d’import de projet Proteus pendant l’installation, vous pouvez le lancer indépendamment depuis le dossier BIN de Proteus V8 (LegacySettingsImporter.exe).

Installation V7.xx personnalisée

Dans ce cas, vous disposez de plusieurs dossiers bibliothèques pour Proteus V.7.

Comme nous n’avons pas connaissance de votre organisation, vous devrez procéder manuellement en copiant les fichiers Proteus V7 dans les bons dossiers de Proteus V8.

L’utilitaire d’import Proteus sera lancé après l’installation et pointera sur un dossier bibliothèque. Si ce dossier correspond au votre, l’utilitaire peut poursuivre son travail normalement. Si ce n’est pas le cas, parcourez les dossiers jusqu’à votre dossier primaire de bibliothèques, puis lancez l’outil.

La gestion d’un second dossier de bibliothèques est à votre charge. Ce dossier peut être ajouté dans Proteus V8, via la commande ‘Définir chemins’ du menu ‘Système’.

Ne changez pas le dossier primaire des bibliothèques de Proteus V8 afin qu’il pointe sur celui de Proteus V7. Ceci provoquera des soucis de fonctionnement.

Si tout cela ne fonctionne pas, vous devrez utiliser l’explorateur de Windows afin de copier manuellement les fichiers depuis les dossiers de Proteus V7 vers les dossiers de Proteus V8.

Fichiers concernés

Les fichiers indiqués ci-dessous sont concernés pas le passage de Proteus V7 en Proteus V8.

Dossier "Library" (bibliothèque)

PROPDEFS.INI : Ce fichier NE doit PAS être copié depuis Proteus V7 car il est totalement différent dans Proteus V8.

SYSTEM.LIB : Ce fichier NE doit PAS être copié depuis Proteus V7 car il est totalement différent dans Proteus V8.

DEFAULT.STY : Ce fichier contient les styles de pastilles et de pistes personnelles et peut être copié dans Proteus V8 depuis Proteus V7. Nous recommandons d’utiliser l’utilitaire de migration qui va fusionner les fichiers, plutôt que d’opérer un remplacement dans le cas d’une copie.

Bibliothèques en lecture seule: Ce sont les bibliothèques fournies par Labcenter. Vous NE devez PAS copier les fichiers de Proteus V7 dans Proteus V8, car nous avons pu ajouter de nouveaux éléments et corriger des erreurs dans Proteus V8.

Fichier VML: Ce sont de fichiers modèles 3D fournis par Labcenter. Vous NE devez PAS copier les fichiers de Proteus V7 dans Proteus V8, car nous avons pu ajouter de nouveaux éléments et corriger des erreurs dans Proteus V8.

Fichier 3DS: Ce sont des fichiers modèles utilisateurs qui peuvent être copiés dans le dossier 'library' de Proteus V8.

Bibliothèques utilisateur: Ce sont des fichiers qui contiennent des composants utilisateurs qui peuvent être copiés dans le dossier 'library' de Proteus V8. Trois bibliothèques sont fournies en standard (USERDVC.LIB, USERPKG.LIB & USERSYM.LIB), bien que l’utilisateur puisse en créer autant que nécessaire.

Fichier IDX: Ce sont des fichiers temporaires générés lorsque Proteus est lancé qui NE doivent PAS être copiés de Proteus V7 vers Proteus V8.

Dossier "Models"

Les modèles qui ont été créés ou téléchargés (t.q. les modèles SPICE) par l’utilisateur peuvent être copiés depuis le dossier ‘models’ de Proteus V7 vers le dossier ‘models’ de Proteus V8. Vous NE devez PAS copier les autres fichiers modèles de Proteus V7 vers Proteus V8 car ils ont pu changer.

Dossier "Template" (gabarit)

Les fichiers gabarits peuvent être copiés depuis le dossier ‘template’ de Proteus V7 vers le dossier ‘template’ de Proteus V8.

Dossier "Datasheets" (notices techniques)

Les notices techniques peuvent être copiées depuis le dossier ‘datasheets’ de Proteus V7 vers le dossier ‘datasheets’ de Proteus V8.

Liste de matériel/Nomenclature

Les configurations de la nomenclature peuvent migrer en lançant le module ‘Nomenclature’ de Proteus V8 (onglet).Vous pouvez lancer cet outil de migration à tout moment via la commande d’import de gabarits (menu ‘Gabarit’) du module nomenclature.

Installation silencieuse / Installation en réseau

Exclusivement pour utilisateurs avancés. Ce paragraphe est destiné aux administrateurs réseaux.

Proteus V8 s’installe via un installateur MSI et nous indiquons ici comment procéder à un déploiement multiple.

La ligne de commande d’installation silencieuse nécessite deux étapes.

1) Extraire le MSI sur le serveur

Depuis la ligne de commande, vous devrez taper une ligne telle que:

setup_pro8.0.15299.0.exe /exenoui /a // /passive /qn TARGETDIR="C:\PROJECTS\PROBUILD\Installers\English\netimg"

où setup_pro8.0.15299.0.exe est l’installateur Proteus et TARGETDIR correspond au chemin d’extraction. Ceci est classiquement exécuté sur le serveur.

2) Installation silencieuse sur le client

Depuis la ligne de commande du poste client, vous devrez taper une ligne telle que:

msiexec /i "\\networkshare\setup_pro8.0.15299.0.msi" /qn DATA_DIR="E:\Proteus\v8data" APPDIR="E:\Proteus\v8" LXK="\\networkshare\licenses\lic.LXK"

Où est indiqué à MSI le chemin d’extraction de l’étape 1, le dossier cible des données du programme et le dossier cible du programme.

Les clés de license peuvent être installées depuis la ligne de commande en ajoutant à l'installateur un paramètre LXK="full\path\to\lic.LXK".

Il faut respecter l’ordre des arguments de la ligne de commande. Pour installer un pack de langue lors de l’installation vous pouvez ajouter à la fin LANG_PACK="chemin complet vers le pack".

Pour éviter d’installer à nouveau un pack de langue, vous pouvez ajouter à la fin NO_LANG_PACK=1.

La propriété KEY_SERVER peut être positionnée dans la ligne de commande pour pointer sur la clé de licence du serveur. Si la propriété est positionnée, la variable d’environnement sera validée, mais pas dans le cas contraire.

Les fichiers ‘batch’ sur le client peuvent apporter une aide dans l’automatisation de cette étape.

Contrôle des mises à jour

Dans de nombreuses institutions ou sociétés, vous voulez contrôler le déploiement des mises à jours sur les ordinateurs 'clients'. Cela est possible en enregitrant les clés de licence sur ces ordinateurs 'clients' de la façon suivante :

HKLM\SOFTWARE\[Wow6432Node\]Labcenter Electronics\Proteus 8 [Professional|Lite|Demo]\Update Manager

UpdateSchedule est une valeur en jours comprise entre 2 et 30. C'est la période de contrôle pour le poste 'client.

IgnoreBetas est une chaîne optionnelle qui peut être ajoutée et définie comme 'true' ou 'false'.

disableUpdateInstallation est une chaîne optionnelle qui peut être ajoutée et définie comme 'true' ou 'false'.

La dernière clé empéchera les postes 'clients' de pouvoir installer les mises à jour de façon indépendante.


Framework

INTERFACE PROTEUS

Généralités

Proteus V8 est composé d'une seule application ou interface qui regroupe plusieurs modules avec différentes fonctionnalités (saisie de schéma, création de circuit PCB, etc.). Cette interface apporte divers avantages dans le développement, en particulier la possibilité pour tous les modules de partager la même base d'information.

Dans la nouvelle interface, de nouveaux termes qui n'existaient pas dans les versions précédentes, sont utilisés..

Module (Application)

Un module "Application" contient les fonctionnalités accessibles depuis un onglet directement dans l'application Proteus. A ce jour, les modules inclus dans l'interface sont:

  • Page d'accueil Proteus
  • Saisie de schéma ISIS.
  • Création de circuits ARES.
  • Visionneur de circuit 3D.
  • Nomenclature.
  • Explorateur de projet.
  • Visionneur Gerber.
  • VSM Studio.
Frame

Une frame caractérise ici une fenêtre de Proteus V8 qui contient plusieurs onglets. Par défaut vous disposez d'une seule frame, bien qu'il soit possible de faire glisser les onglets pour créer des nouvelles frames ou pour les fermer.

Onglet

Un onglet se situe en haut de la frame. Lorsqu'on clique sur un onglet, un module application s'ouvre dans la partie inférieure. Vous pouvez également glisser-déposer les onglets vers d'autres moniteurs (ou dans une zone libre de l'espace de travail) afin qu'ils s'ouvrent dans de nouvelles frames.

La suite est un résumé des modifications effectuées au plus niveau dans la présentation de Proteus.

Gestion des fichiers

Proteus V8 utilise le nom de fichier d'extension "pdsprj". Tous les fichiers modules sauvegardent leur données dans ce fichier "pdsprj".

Schéma et PCB

  • Les données de la saisie de schéma sont sauvegardées dans le fichier "pdsprj".

  • Les données relatives au circuit imprimé sont sauvegardées dans le fichier "pdsprj".

  • Il vous sera demandé de sauvegarder votre fichier de génération de la nomenclature sur disque.

  • Il vous sera demandé de sauvegarder vos fichiers nécessaires à la fabrication du circuit imprimé sur disque.

  • Il vous sera demandé de sauvegarder vos fichiers PDF, les sorties graphiques du schéma et le PCB sur disque.

Schéma et VSM

  • Les données du schéma sont sauvergardées dans un fichier "pdsprj".

  • Les fichiers de code source sont par défaut sauvegardés dans le fichier "pdsprj".

  • La configuration de débogage des fichiers "objets" est sauvegardée dans le fichier "pdsprj" pour la simulation VSM.

  • Le fichier "hex" est copié à l'extérieur du fichier "pdsprj" afin de programmer le hardware physique.

Vous pouvez décider de sauvegarder vos fichiers sources à l'extérieur du fichier "pdsprj" en décochant la case 'attacher fichiers' dans la configuration du projet de VSM Studio.

Le principal objectif de cette organisation est de conserver tout ce qui concerne Proteus dans un seul fichier puis de sauvegarder en externe les informations utiles à d'autres applications.

De plus, le fichier "pdsprj" de Proteus V8 mémorise l'espace de travail de chaque projet.

Les états sauvegardés sont:

  • Nombre de frames ouvertes.
  • Nombre d'onglets ouverts et quel onglet est associé à quelle frame.
  • Taille et position de(s) frame(s) sur le(s) moniteur(s).

Menus et icônes

La plupart des menus et des commandes restent inchangés par rapport à Proteus V.7. Cependant, ils commuteront automatiquement lorsque vous cliquez sur un onglet. Par exemple, si vous avez un onglet ISIS et un onglet ARES, le fait de cliquer dans l'onglet ISIS validera les menus et les icônes de ce module et le fait de cliquer dans l'onglet ARES, remplacera les menus et les icônes par ceux d'ARES.

Naturellement de nouvelles icônes apparaissent et certaines fonctionnalités changent de place, comme résumé ci-dessous:

Nomenclature

La nomenclature (Bill of Matériel ou BOM) de Proteus V8 est maintenant un des principaux modules d'application. Ce module peut être lancé depuis la barre d'outils de toute fenêtre Proteus.

Page d'accueil

La page d'accueil est un nouveau module application de Proteus V8 et peut être lancée depuis la barre d'outils de toute fenêtre.

Visionneur 3D

Le visionneur 3D est un nouveau module application de Proteus V8 et peut être lancé depuis la barre d'outils de toute fenêtre.

Visionneur et éditeur Gerber

Le visionneur/éditeur Gerber est un nouveau module de Proteus V8.

Visionneur Gerber vs Editeur Gerber

VSM Studio IDE

Proteus V8 inclut son propre environnement de développement intégré EDI (VSM Studio). il est présent dans l'application principale en tant que module principal et peut être lancé depuis la barre d'outil du module application.

Gestionnaire de mise à jour

Le gestionnaire de mise à jour est intégré dans la page d'accueil et les anciennes commandes de mise à jour ont été supprimées.

Popups actifs

Les popups actifs sont une nouvelle fonctionnalité de la simulation de Proteus 8 et possèdent leur propre icône dans la barre d'outils d'ISIS.

Onglets et frames

Chacun des principaux modules de Proteus possède son onglet dans la frame courante.

Si vous le souhaitez (particulièrement si vous travaillez avec 2 moniteurs), vous pouvez glisser-déposer un onglet dans un espace libre pour créer une nouvelle frame.

Ceci permet de visualiser les deux modules en même temps, avec la base de données commune et la netlist temps réel en tâche de fond.

Pour ouvrir un nouvel onglet

Pour ce faire, il suffit de cliquer sur l'icône du module souhaité dans la barre d'outils.

L'exception à cette règle concerne les graphes qui s'ouvrent dans un nouvel onglet lorsqu'il sont maximisés.

Aucun module application n'est associé aux graphes dans la barre d'outils car ils ne sont placés que dans le schéma.

L'explorateur de projet peut également être ouvert depuis le menu contextuel des composants dans ISIS ou des boîtiers dans ARES.

Pour fermer un onglet

Pour fermer un onglet, il faut cliquer sur la croix située en haut et à droite de l'onglet.

Le fait de fermer une fenêtre "application" ferme également tous les onglets rattachés à cette frame.

Pour ouvrir une fenêtre application supplémentaire

Supposons que les onglets ISIS et ARES sont ouverts et que vous souhaitiez les voir en même temps. Glissez l'onglet ARES vers l'autre moniteur ou dans une zone vierge de l'écran.

OU

Double-cliquez sur l'onglet ARES pour ouvrir une nouvelle fenêtre sur le même moniteur.

Pour fusionner deux fenêtres application

Pour regrouper à nouveau les fenêtres, il suffit de glisser l'onglet ou la fenêtre depuis la seconde fenêtre au-dessus de la première. La différence est assez subtile entre ces deux techniques car le fait de glisser l'onglet seul regroupera seulement cet onglet alors que le glissement de la fenêtre regroupera TOUS les onglets ouverts de celle-ci.

Pour fermer une fenêtre application

Utilisez la croix placée en haut de la fenêtre pour la fermer. Si plus d'une fenêtre est ouverte, il vous sera demandé de fermer soit la fenêtre courante, soit l'application globale.

Page d'accueil

La page d'accueil est un nouveau module d'application de Proteus V8. La plupart des liens contenus dans ce module sont évidents alors que d'autres nécessitent quelques explications.

Nouvel assistant de projet (Project Wizard)

L'assistant vous guide dans l'initialisation de votre projet Proteus V8. Sur la page de lancement, il faut indiquer le nom du projet et le dossier de destination. Sur cette page, vous apercevez également trois écrans qui correspondent au schéma, au circuit (PCB) et à l'interface du logiciel.

Schéma

Si vous créez un schéma, cochez les cases en haut de l'écran, puis choisissez le gabarit sur lequel votre schéma sera basé. Les gabarits fournis par Labcenter contiennent différentes tailles d'espace de travail, sachant que vous pouvez créer vos propres gabarits dans le module de saisie de schéma.

PCB

Si vous cochez la case PCB en haut de l'écran, vous devrez choisir un gabarit. Les gabarits disponibles pour les circuits contiennent des bords de carte prédéfinis, des trous de fixation et des données technologiques (règles de conception, couches, unités par défaut, etc). Comme pour le schéma, vous pouvez personnaliser ces gabarits dans le module de création de circuit.

Cet écran ne vous sera présenté que si vous disposez d'une licence Proteus PCB.

Couches de circuit imprimé

Cette fenêtre vous permet d'ajuster directement la liste des couches définie dans le projet PCB que vous avez sélectionné sur l'écran précédent. Vous pouvez ajouter ou supprimer des couches ou les renommer. Cette étape permet de simplifier la sélection des filtres pour les opérations comme le placement de pistes.

Cette fenêtre n'est disponible que lorsque vous travaillez sur un projet PCB.

Firmware

Si vous créez un projet enfoui avec le souhait de simuler votre firmware, cochez la case 'firmware' en haut de l'écran, puis choisissez un processeur et un compilateur. Si vous cochez la case 'Créer fichiers rapides', un squelette de firmware sera généré et le projet sera configuré pour la compilation.

La création d'un projet avec firmware nécessite un schéma. Il n'est donc pas possible de simuler un firmware depuis cet écran sans avoir créé un schéma dans l'étape précédente de l'assistant.

Cet écran ne vous sera présenté que si vous disposez d'une licence firmware pour le contrôleur à simuler dans Proteus.

Assistant d'import de project

L'import de projet via l'assistant permet d'importer rapidement des projets issus des versions précédentes dans Proteus V8.

Pour importer un projet d'origine

Recherchez l'ancien schéma (.dsn file)

Si un fichier circuit imprimé (.lyt file) est associé au schéma il apparaîtra automatiquement dans le champ circuit (Layout). Si aucun fichier circuit n'est associé, veuillez laisser ce champ vide.

Si un ancien fichier VSMstudio existe(.vsmp) de même nom et dans le même dossier que le schéma, il apparaîtra dans le champ firmware. Si le nom de fichier n'est pas le bon ou qu'aucun firmware n'est associé, recherchez le bon fichier ou laissez ce champ vide.

Le nom de projet et le schéma sont automatiquement renseignés mais vous pouvez les modifier dans la partie inférieure de la boite de dialogue.

Lorsque le paramètrage de l'import est terminé, utilisez le bouton Import pour créer le projet Proteus V8.

Si vous changez le chemin d'un projet VSM, vous devrez modifier manuellement la propriété PROGRAM du microcontrôleur, sans quoi la simulation ne se lancera pas.

A ce stade du schéma, les projets PCB et les couches ont été crées de la même façon dans Proteus V8 que dans Proteus V7. Cependant, il n'y a pas de lien entre les deux et aucune information de netlist ne passe entre le schéma et le circuit (la netlist temps réel n'est pas active). Pour l'instant, la relation entre la connectivité du schéma et la connectivité du circuit; nous ne voulons pas apporter des modifications à une couche si cela n'a pas été décidé par le concepteur du projet PCB. Après avoir contrôlé que l'import s'est bien déroulé, vous devez activer la netlist temps réel via l'option disponible dans le menu OUTILS du module ARES, avant de travailler sur votre projet.

Le seul cas qui suppose de travailler sans netlist temps réel est celui d'un projet utilisant de nombreuses couches avec des zones multiples, car la netlist temps réel pourrait être pénalisante, la connectivité des zones étant recalculée à chaque modification du schéma.

Si vous importer un projet mais n'activez pas la netlist temps réel avant de travailler dessus, vous allez travailler dans ARES sans netlist. Ce n'est pas recommandé.

Nouveautés et information

La zone "nouveautés et information" de la page d'accueil est une zone de communication et de notification. Son contenu évoluera en fonction des mises à jour.

Modes d'affichage

Le projet contient principalement 3 fenêtres de visusalition : la saisie de schéma, la création du circuit imprimé et le visionneur 3D. Dans Proteus V8, chaque module supporte 2 technologies d'accélération hardware en plus du rendu Windows standard.

Si votre carte graphique accepte les accélérations matérielles, vous pouvez choisir soit le mode OpenGL, soit le mode Direct 2D/3D en utilisant la commande 'Options d'affichage' du menu 'Système' du module approprié.

Les performances et le rendu de l'accélération matérielle dépendront de votre carte graphique et des pilotes.

Mises à jour du logiciel

La page d'accueil vous informe des mises à jour disponibles. Les notifications de mises à jour apparaîtront dans la zone 'nouveautés et information'. Vous pourrez alors activer le téléchargement ainsi que l'installation du logiciel immédiatement.

Rapport d'erreurs

Proteus V8 introduit un nouveau système de rapport d'erreurs. Si le logiciel 'plante' du manière inattendue, au lancement suivant vous pourrez transmettre le dump du plantage à Labcenter. Ce dump permet de situer la source du problème et nous aide à améliorer le logiciel plus rapidement.

La transmission réussie du dump sera indiquée dans la zone 'nouveautés et information' de la page d'accueil et vous recevrez une notification de la correction éventuelle suite à cette transmission.

Nous vous incitons fortement à nous transmettre les dumps afin que nous puissions améliorer la qualité du logiciel.

Il est important de comprendre que les fichiers dump ne sont pas infaillibles. La source du problème ne réside pas nécessairement à l'endroit du plantage et - dans le cas de problèmes mémoire ou de pile - le fichier dump sera peu utile. Cependant, ces dumps nous permettent de prendre connaissance d'un problème et fournit un point de départ à sa résolution.

La transmission de fichier dump est validée par défaut mais, si vous le souhaitez, vous pouvez l'invalider grâce à la commande 'Configuration système' du menu 'Système'.


Netlist

NETLISTS

Généralités

Une netlist (liste des liens) résulte de l'extraction des données électriques d'un outil de CAO électronique dans une forme qui peut être interprétée par un autre outil de la CAO.

Dans un projet de CAO traditionnel, la netlist est créée dans l'outil de saisie de schéma pour être transmise lorsqu'on appuie sur un bouton. Dans le cas de Proteus V8, il n'est pas nécessaire de valider la mise à jour de la netlist car celle-ci est mise à jour instantanément dans les autres modules. Proteus V8 utilise le principe de la netlist temps réel et nous indiquons dans la suite du document comment les modules sont affectés par cette netlist temp réel.

Saisie de schéma (ISIS)

Dans Proteus, le module de saisie de schéma génère une netlist et la transmet au reste du système. Lorsque le schéma est modifié et que sa connectivité électrique est affectée (placement, liaison, suppression, ....), la netlist est modifiée en arrière-plan.

Circuit imprimé (ARES)

Le module de création de circuit reçoit les données de la netlist depuis la saisie de schéma de 2 façons

  1. Lorsque la netlist temps réel est validée, les données sont reçues par le module ARES ouvert ou visible.

  2. Lorsque la netlist temps réel n'est pas validée, vous devrez cliquer manuellement sur l'icône cadenas situé dans le bas d'ARES pour mettre à jour la netlist. L'icône cadenas apparaîtra lorsque des modifications de netlist sont intervenues dans ISIS, sans avoir été mises à jour dans ARES.

Netlist temps réel ON

Lorsque la netlist en temps réel est validée, chaque modification apportée au schéma est directement reçue par le module de circuit imprimé si celui-ci est ouvert ou dès qu'il est placé en premier plan.

Une modification d'ajout met à jour le circuit. Par exemple, l'ajout d'un lien dans ISIS ajoutera une ligne de chevelu dans ARES.

Une modification dans ISIS qui supprime des pistes ou des composants, nécessitera une confirmation manuelle dans le circuit. Les objets qui auront été supprimés du schéma seront visuellement repérés dans ARES et pourront être supprimés lorsque vous cliquez sur 'modification en attente" pour valider le synchronisme avec le schéma.

Netlist temps réel Off

Dans l'ancien système, il fallait presser un bouton pour transférer la netlist d'un schéma au circuit. Désormais, la netlist temps réel Off est un mode d'opération batch et plus seulement une mise à jour automatique de la netlist et ceci pour deux raisons principales :

Importer d'anciens projets

Il est important que lors de l'import de projet, la netlist ne soit pas automatiquement transférée pour ne pas risquer de perturber le circuit sans un consentement explicite de l'utilisateur. la netlist temps réel est inactive après l'import de projet et elle doit âtre activée manuellement par la suite.

Voir également:

Importer des anciens projets Version 7

Projets de taille importante

La netlist temps réel peut être problématique pour les projets de taille importante car la connectivité des zone est recalculée à chaque modification du schéma (particulièrement sur les schémas avec des plans de masses multiples). Il est cependant important de noter que quitter la netlist temps réel et fermer simplement l'onglet ARES suffit - les mises à jour n'interviendront pas en arrière-plan.

Comment cela fonctionne?

Lorsque la netlist temps réel n'est pas validée, une modification apportée au schéma verrouillera le circuit imprimé jusqu'à ce que vous ayez accepté les nouvelles données de netlist. Il suffit pour cela de cliquer sur l'icône cadenas 'hors sync' placé dans la partie inférieure d'ARES. C'est l'équivalent de la commande 'Netlist vers ARES' des versions précédentes de Proteus.

Lorsque la nouvelle netlist est reçue, une demande d'acceptation des modifications en attente peut également vous être demandée si des suppressions concernent des objets déjà sur le circuit.

Commutation de mode de Netlist

Lorsqu'un nouveau projet est créé, la netlist temps réel est validée par défaut. Vous pouvez commuter cet état dans le menu 'Outils' d'ARES.

Lorsque vous importez un projet d'une ancienne version de Proteus, la netlist temps réel est invalidée par défaut afin de ne pas apporter de perturbations au projet. Vous pouvez commuter en netlist temps réel grâce au menu 'Outils'.

Nous supposons que pour la plupart des développement, les utilisateurs préfèreront le mode netlist temps réel. Cependant, pour les circuits de grande dimension qui incluent des nombreux plans de masse, les performances peuvent être dégradées car la connectivité des plans de masse sera recalculée à chaque modification du schéma. Dans ces situations, il est préférable de se placer sur OFF afin que les mises à jour soit faites sur demande.

Nomenclature

Le module 'Nomenclature' reçoit la netlist temps réel du schéma lorsqu'il est ouvert et visible. Les données lues dans la netlist sont utilisées pour remplir la fenêtre de la nomenclature qui sera automatiquement mise à jour lorsque le schéma est modifié.

Explorateur de projets

Le module 'Explorateur de projet' reçoit la netlist temps réel du schéma lorsqu'il est ouvert et visible. Ceci permet de mettre automatiquement à jour les vues des éléments physiques (partlist - liste des éléments) et électriques (netlist - liste de connexions) pour refléter l'état courant du schéma.

Simulation

La simulation utilise une netlist différente de celle utilisée par l'outil de circuit imprimé (netlist logique plutôt que physique). Celle-ci fonctionne comme celle des versions précédentes de Proteus.


Schematic

Saisie de schéma

Généralités

Les opérations de base d'ISIS sont identiques aux versions précédentes de Proteus. La plupart des différences sont internes, telles que les informations sur les éléments qui sont écrites dans la base de données commune ainsi que celles sur la connectivité qui sont tenues à jour dans une netlist temps réel.

Les modifications les plus évidentes sont visibles dans la Liste du matériel et l'explorateur de projet qui sont présents dans des onglets et interagissent avec le schéma. Ce qui suit est un résumé des changements internes à ISIS.

Composants Multi-Elements

Un composant multi-éléments est un composant physique unique qui contient plusieurs éléments logiques. La base de données gère les éléments globalement et il n'est pas possible d'affecter des propriétés conflictuelles, dont le fait de modifier la propriété dans un élément répercutera automatiquement la propriété dans tous les autres éléments du composant.

Annotation & permutations de portes

L'annotation et la permutation de portes de la boite d'édition du composant fonctionne de manière légèrement différente. Voyons l'exmple suivant:

Lorsque l'élément est placé, nous connaissons sa référence (t.q. U1) et l'identifiant de l'élément (t.q. A). Dans la boite de dialogue, ces informations sont présentes dans deux champs.

Reference du composant

Le fait de changer la référence d'un composant provoquera une nouvelle annotation de tous les élements. Par exemple, changer U1 en U4 affectera tous les éléments de U1 en des éléments de U4. Vous obtiendrez un message d'avertissement si vous utilisez une référence déjà présente dans le schéma.

Pour ré-annoter U1 en U4

Editez un des éléments de U1 et changez la référence en U4.

Pour permutter U4:A avec U4:C

Editez l'élément U4:A et changez l'élément en U4:C.

Pour annoter un composant hétérogène

Si vous avez un composant multi-éléments hétérogènes comme un relais qui comprend une bobine et des contacts, le processus est similaire à celui des versions précédentes. Une fois que vous avez placé les éléments sur le schéma, ils ne seront pas automatiquement annotés car les composants hétérogènes nécessitent une annotation manuelle.

L'annotation de chaque élement prend la forme ci-dessous:

<part ref> : <element>

et est rentrée dans le champ de référence du composant de la boite de dialogue. Par exemple, la bobine peut être annotée RL1:A et le contact comme RL1:B et RL1:C.

Nous considérons ici que les contacts sont identiques, par conséquent, vous pouvez les permutter via le champs 'Elément' de la boite de dialogue d'édition des composants.

La permutation n'est possible que si les éléments contacts proviennent de la même biblothèque.

Elements sans package

Dans Proteus V8, vous n'êtes pas obligé de définir le package d'un élément avant qu'il soit importé dans ARES. Les éléménts sans package apparaîtront dans le sélecteur d'objets d'ARES avec ceux qui possèdent une empreinte. Lorsque vous tenterez de placer un élément sans package, ARES vous demandera de lui affecter un boîtier physique.

Terminaux physiques

Les terminaux physiques ne nécessitent plus de scripts pour leur associer une empreinte physique. Eux-aussi tirent parti des éléments non-packagés décrits ci-dessus. Lorsque vous placez un ou plusieurs terminaux physiques en relation avec un composant, ils apparaîssent dans la liste des objets d'ARES et une empreinte physique doit leur être associée lors du placement.

Ne pas utiliser *FIELD blocks dans Proteus V8.

Exclure de la nomenclature

La boite de dialogue d'édition d'un composant d'ISIS contient une case à cocher supplémentaire qui permet d'exclure le composant de la nomenclature. Ceci est très pratique pour produire différentes variantes d'un circuit.

Import graphique

L'import d'un graphique comme le logo d'une société a été rationnalisé et étendu afin d'inclure de nouveaux formats, tels que:

PNG

JPEG

GIF

Tous les imports se font via une nouvelle commande d'import d'image dans le menu 'Fichier'. Vous devez ensuite sélectionner le format souhaité dans la partie inférieure de la fenêtre qui s'ouvre.

Contrôle croisé avec le circuit

Vous pouvez vérifier le package placé associé au composant d'ISIS via le menu contextuel du composant. Si l'élément n'est pas placé sur le circuit, il ne se passera rien..

Spécification de la classe du lien

Vous pouvez, à présent, configurer les classes de lien dans le schéma. Entre autres, les classes de liens permettent d'indiquer les largeurs des pistes ou des traversées qui sont utilisées dans le circuit. Ces classes se retrouvent également dans le gestionnaire des règles de conception d'ARES où il est possible de configurer les distances d'isolement (clearances) de chaque classe.

Pour définir une classe, cliquez droit sur un fil du schéma, choisissez l'option de placement d'un label de fil dans le menu contextuel, puis validez l'onglet 'Classe de lien' de la boite de dialogue.

Choisissez une classe de liens existante dans la liste déroulante ou créez une nouvelle classe grâce au bouton 'Nouveau'.

Dès que la classe est validée, vous pourrez configurer les caractéristiques.

Les distances d'isolement du projet sont configurées dans le gestionnaire des règles de conception du menu 'Technologie' d'ARES. Chaque classe de liens possède ses propres paramètres.


PCB

CIRCUIT IMPRIME PCB

Généralités

Les opérations de base d'ARES sont globalement identiques à celles des versions précédentes. La différence principale réside dans la façon dont les différents modules interagissent entre eux. Par exemple, vous pouvez désormais avoir les représentations 2D et 3D du circuit ouvertes dans des fenêtres en même temps. De plus, la vue 3D sera mise à jour automatiquement en fonction des modifications apportées à la vue 2D. Nous indiquons ci-dessous le résumé des principales modifications apportées à ARES.

Netlist et synchronisation

La communication entre le schéma et le PCB a évolué dans Proteus V8. Il est possible de travailler avec une netlist temps réel ou une netlist en mode batch. Un nouveau contrôleur de connectivité existe dans ARES qui gère la synchronisation entre le circuit et le schéma. Ceci remplace l'ancienne fonction 'Netlist vers ARES' de Proteus V7. Par défaut, l'état de la connectivité réside dans la partie inférieure de l'interface, à côté du gestionnaire des règles de conception. A chaque instant vous obtiendrez 1 état parmi 4 possibles.

Pas de Netlist

C'est l'état qui intervient si:

  • Il n'existe pas de connexions dans le schéma.
  • Vous avez effacé la netlist (Menu 'Outils' - Effacer netlist) manuellement et la netlist temps réel est sur la position off.

Vérrouillé

L'état verrouillé est indiqué lorsque la netlist temps réel est sur off et que des modifications apportées au schéma n'ont pas été répercutées sur le circuit PCB. Dans cet état, l'édition du circuit n'est pas validée. Le fait de cliquer sur l'icône de verrou appliquera au circuit les modifications du schéma, ce qui rendra actif l'édition du circuit. A ce stade, si vous avez modifié le schéma en supprimant des éléments, vous devrez valider les modifications en attente (voir ci-dessous).

Modifications en attente

Cet état est présent lorsque les informations courantes du schéma ont été transmises au circuit et que certains éléments attendent votre confirmation.

Vous obtiendrez cet état lorsque des modifications sont intervenues dans le schéma qui impliquent la suppression d'objet(s) dans le circuit. Les éléments et/ou les pistes concernés seront repérables visuellement pour indiquer qu'ils/elles ne sont plus valides et vous aurez deux choix:

  1. Cliquer sur le bouton 'Modification en attente' pour confirmer les modifications. Les objets repérés disparaîtront et le circuit sera à nouveau synchronisé.

  2. Revenir sur les modifications du schéma soit manuellement, soit via le bouton 'Défaire'. Les objets repérés seront installés à nouveau et les modules schéma-PCB seront synchronisés.

Il faut comprendre que les objets repérés (grisés) ne sont plus présents sur le circuit, mais simplement repérés visuellement. Ce mécanisme montre à l'utilisateur l'impact des modifications apportées au schéma et nécessite la décision de poursuivre ou de revenir à l'état précédent.

Si le repérage des objets grisés est difficile, vous pouvez modifier la couleur dans la boite de dialogue 'Editer couches/Visibilité' du menu 'Affichage'.

Affichage CRC (Contrôle des règles de connectivité) temps réel

Vous obtenez cet état lorsque la netlist est chargée et que le schéma est synchrone avec le circuit, c'est à dire la plupart du temps! L'affichage évoluera pour indiquer le nombre de connexions manquantes sur le circuit en liaison avec les liens du schéma.

Le fait de cliquer dans cette zone ouvrira une fenêtre texte qui liste les connexions manquantes. Vous pourrez accéder à une connexion par un double-clic sur la ligne de la liste.

Commuter de mode de netlist

Vous pouvez commuter entre le mode de netlist temps réel et le mode de netist batch grâce à la commande 'Netlist temps réel' du menu 'Outils' d'ARES.

  • Les nouveaux projets sont positionnés en mode netlist temps réel ON

  • Les projets Proteus importés sont positionnés en mode netlist temps réel OFF. C'est nécessaire car il peut y avoir des erreurs de netlist présentes dans ces projets importés.

  • Tous les projets ouverts mémorisent l'état de netlist de la session précédente.

Erreurs de netlist

Il n'est pas possible d'être en netlist temps réel lorsque des erreurs sont présentes car le système impose que la netlist soit valide. Vous devrez donc résoudre ces erreurs de netlist lorsqu'elles sont présentes.

Si vous travaillez en netlist temps réel OFF, vous devrez résoudre les erreurs de netlist pour pouvoir déverrouiller ARES.

Les erreurs de netlist apparaîtront dans un onglet séparé lorsque la netlist est transférée du schéma vers le circuit. Par exemple, si vous avez des rails d'alimentation qui ne sont pas connectés, vous obtiendrez des erreurs de netlist comme indiqué ci-dessous:

Vous devrez résoudre ces erreurs en connectant les alimentations dans la boite de dialoque des rails d'alimentation.

Voir également

Netlists

Supprimer des boîtiers

Dans Proteus V8 il existe 2 façons de supprimer une empreinte placée; vous pouvez supprimer le boîtier directement dans ARES ou vous pouvez supprimer le composant associé dans ISIS

  • Si vous supprimez le boîtier directement dans ARES, les pistes placées reliées au boîtier resteront.

  • Si vous placez le composant dans ISIS, lorsque vous cliquerez sur modifications en attente dans ARES, le boîtier et les pistes connectées au boîtier seront supprimés.

Opérations sur des portions de projets

La nature d'un copier/coller d'un bloc que vous pouvez prendre une portion de circuit dont l'annotation est liée à des composants du schéma. Si elle ne correspond pas aux bons composants du schéma au moment où l'on extrait cette portion de projet, vous risquer de casser des liens de composants auxquels vous ne vouliez pas toucher. Avant de coller une bloc vous devez :

  • Nettoyer la netlist (Menu OUTILS)
  • Copier/Coller le circuit
  • Re-annotater comme souhaité pour mettre en relation les composants de votre schéma
  • Activer la netlist (Menu OUTILS)

Il est préférable et conseillé d'utiliser les portions de projet pour ces opérations.

Voir Vidéo Introduction aux portions de projet.

Retro-annotation

L'annotation dans la Version V8 est largement plus simple et plus flexible que dans les versions précédentes. Cependant, de légères différences existent selon le mode de netlist validé.

Annotation manuelle

Lorsque la netlist temps réel est validée, une modification de l'annotation apportée au circuit se reporte immédiatement au schéma et vice versa. Aucune confirmation n'est requise.

Lorsque la netlist temps réel n'est pas validée, une modification de l'annotation apportée au circuit se reporte au schéma et le PCB est placé en état verrouillé. Une modification de l'annotation dans le schéma ne sera pas répercutée dans le circuit, mais placera ARES en état non synchrone.

Dans les deux cas, le fait de cliquer sur le bouton 'Déverrouiller' appliquera la netlist et le circuit pourra être édité.

Annotation automatique (globale)

L'annotation globale du PCB (Menu 'Outils - Annotateur automatique) a été améliorée avec de nouvelles options.

Lancer cette commande est comparable à de l'annotation manuelle, ce qui commutera ARES en mode verrouillé avec la netlist temps réel non validée.

La position des éléments sur le circuit est totalement arbitraire et toute tentative de ré-annoter le circuit est sujette à caution. Il faut donc vous attendre à devoir reprendre manuellement les annotations obtenues.

Sélection intelligente d'éléments

Lorsque vous commencez à définir votre circuit après que le schéma soit terminé, il arrive souvent que de nombreux éléments à placer ne sont reconnus que par leur référence, ce qui peut se révéler très frustrant.

Proteus inclut 2 nouvelles fonctionnalités à ARES pour simplifier le processus:

  1. Les valeurs des éléments sont affichées avec les réféfences
  2. L'affichage du contenu peut être limité à une portion du schéma

Pour limiter le contenu des éléments

Dans ISIS, placez-vous en mode sélection, maintenez le bouton gauche de la souris enfoncé et étirez un rectangle autour de la zone d'intérêt.

Dans ARES, placez-vous en mode composant et choisissez le mode 'tagged' dans la liste des composants à placer.

Contrôle-croisé avec le schéma

Vous pouvez maintenant retrouver le composant du schéma directement depuis l'empreinte du circuit. Lorsque le composant contient plusieurs éléments, il vous sera démandé de choisir l'élément souhaité. Vous ne pourrez par lancer cette opération si la netlist temps réel est sur OFF avec un circuit verrouillé.

Visualisation Gerber / Edition Gerber

Quand vous voulez créer un fichier de sortie CADCAM à partir de ARES, vous avez la possibilité de visualiser le résultat dans le visionneur Gerber. Cette action ouvre un nouvel onglet.

Si vous souhaitez ajouter des information ou réaliser un panneau, vous devez d'abord fermer le projet en cours, puis ouvrir le module gerber et charger vos fichiers CADCAM.


3DV

VISIONNEUR 3D

Généralités

Comme la plupart des modules de la suite Proteus V8, le visionneur 3D a subi de profondes évolutions. C'est maintenant un module à part entière que vous retrouvez directement sur l'interface Proteus. Le rendu et la façon dont le circuit est calculé ont été améliorés

Technologies d'affichage

Comme pour les autre modules de dessin dans Proteus, le visionneur 3D a été mis à jour pour permettre un rendu avec Direct 3D (élément de Direct X). Si votre carte graphique admet une accélération hardware, vous pourrez choisir entre les modes de rendu OpenGL et Direct 3D. Des options telles que le multi-échantillonnage seront validées en fonction des possibilités des pilotes de la carte graphique.

Rendu multi-coeurs

Le rendu des scènes 3D tient compte des possibilités multi-thread des processeurs multi-coeurs actuels .

En relation avec les performances de votre ordinateur et, en particulier, du nombre de coeurs disponibles, vous obtiendrez un gain de performance compris entre 30% et 50%.

Actualisation automatique depuis ARES

Le visionneur 3D sera mis à jour lorsque des objets d'ARES sont ajoutés/supprimés (visionneur ouvert et visible). La mise à jour du rendu peut être instantanée ou prendre 1 à 2mn en fonction de la complexité du circuit et des performances de votre ordinateur.

Dans la pratique, pour des circuits de complexité moyenne, vous pourrez disposer d'un rendu 2D (ARES) et 3D simultané.

Visualisation pré-définies

En plus des vues pré-définies du circuit, vous pouvez, à présent, tourner le circuit autour de la position courante de la caméra. Ceci permet, par exemple, de contrôler très facilement le dessous du circuit autour d'un composant. Les vues pré-définies fonctionnent de manière identique quelle que soit la face du circuit en cours de visualisation.

Vues pré-définies avec la nouvelle option de rotation.

Si vous désirez contrôler finement la position du circuit, vous pouvez utiliser la navigation manuelle qui fonctionne comme dans les versions précédentes.

Lumière spéculaire

Un bon contraste entre les objets en cuivre (pistes, circuit, zone de masse, etc) est obtenu en appliquant un éclairage d'angle. Cette fonctionnalité a été améliorée dans Proteus V8 avec l'introduction d'une lumière spéculaire. Cette technique imite la façon dont la lumière se refléchit sur les objets et améliore la visualisation en tenant compte de la lumière ambiante, diffuse et de l'axe de rotation du circuit.